4.6 and rapid deployment

May 3, 2011 at 3:01 PM

Hi,

I've succesfully got the clean Umbraco install going and all looks good.

I'm now having a go at moving a local 4.6 install over with the Rapid Deployment tool (which is great by the way).

However, it seems the runtime environment framework is defaulting to .net 3.5, and obviously throwing up an assemby error.

How can I force v4.0.30319? I've tried adding:

<startup useLegacyV2RuntimeActivationPolicy="true">
            <supportedRuntime version="v4.0.30319" />
        </startup>

To the config, but without any luck.

Is this possible? do I need to make some changes to the AcceleratorWorkerRole assembly?

Thanks for any help.

Tom

May 3, 2011 at 5:41 PM

Hi Tom,

I would recommend you take a look at the new Windows Azure Accelerator located here: http://waacceleratorumbraco.codeplex.com - with it you will be able to run the newest version of Umbraco (4.7.0) .NET 4.0 on Azure with multiple instances.
As far as I remember the Rapid Deployment Accelerator uses (or deploys to) an older version of Azure OS that doesn't work with .NET 4.0 and Umbraco 4.6 and newer.

Morten

May 3, 2011 at 8:59 PM

Thanks Morten - worked first time, up and running in an hour.