Rich text editor does not work with Umbraco Azure Accelerator

Feb 4, 2011 at 4:38 PM
Edited Feb 4, 2011 at 4:40 PM

It seems like it is not possible to use the RichText data type in Umbraco when deployed to Azure using the Accelerator.

I deployed Umbraco using the package and scripts found here: http://azureaccelerators.codeplex.com/documentation and then created a simple document type/template/page with a RichText property. When I try to edit that page the richtext editor won't show up. When I run Fiddler to check the data sent/received I noticed that all requests for /umbraco_client/tinymce3/ and below fails with http status 502.

When I examined the request sent from the browser to the server I noticed that suddenly it tried to call my host on port 20000. A few requests earlier I found that the page http://<host>/umbraco/plugins/tinymce3/tinymce3tinymceCompress.aspx returned javascript that also mentioned port 20000 (see below).

HTTP/1.1 200 OK
Cache-Control: public
Content-Type: text/javascript; charset=UTF-8
Expires: Mon, 14 Feb 2011 16:32:43 GMT
Server: Microsoft-IIS/7.0
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Date: Fri, 04 Feb 2011 16:32:43 GMT
Content-Length: 532685

var tinyMCEPreInit = {base : 'http://<host>:20000/umbraco_client/tinymce3', suffix : '_src'};(function(win) {
    var whiteSpaceRe = /^\s*|\s*$/g,
        undefined;

    var tinymce = {
        majorVersion : '3',

        minorVersion : '3.3',

        releaseDate : '2010-04-19',

Is this due to a bug in the accelerator?

/Martin

 

PS

I just noticed EwaB's post from wednesday 'Deployment Accelerator - content editing toolbar' that seems to be about the same problem

DS

Mar 31, 2011 at 10:39 PM

esping2 did you find the solution to this error? I have the same problem.