Deployment Accelerator - doubled $ sign in SQL Azure server admin password

Feb 3, 2011 at 9:48 AM
Edited Feb 3, 2011 at 12:30 PM

I would like to describe what I have faced using the Umbraco Azure Deployment Accelerator for the first time. Finally I succeeded but my first attempt was really unlucky. I performed all the checklist steps and when I launched the Umbraco site form the cloud I got message stating umbraco database authorization problem. I was really puzzled because in the meantime I checked that the umbraco database was successfully created by the SetupUmbraco.bat script. I decided to download the vhd from the cloud to my local computer to be able to attach it locally and check the umbraco connection string in the web.config file. And what I discovered?!

My SQL Azure server had following admin password set – Pa$$w0rd1 (the double $ sign is the key of the story). I put this password in the ServiceConfiguration.cscfg configuration file before running the SetupUmbraco.bat script (SetupUmbraco.bat script output below)



But having a look at the umbraco connection string in web.config on vhd downloaded from the cloud I noticed it didn’t contain the double $ - there was only one dollar sign in the password!


I did everything once more setting different password to my SQL Azure server but still having double $ sign in it. And again with the same result. It’s incredible but fortunately repeatable. When I chose another password containing only single $ sign or other doubled letters (for instance ss) everything worked fine.

Strange, isn’t it?

Best regards
EwaB