Errors with AccelCon.exe with the Azure SDK console

Jan 11, 2011 at 12:29 PM

Hello,
I am currently trying to use the AccelCon.exe application with the windows SDK command line tool to publish the VHD onto Azure without any luck.

When following your getting started guide step by step I still encounter the following error:

"Unhandled Exception: System.BadImageFormatException: Could not load file or assembley ' Microsoft.WindowsAzure.Acceleerator, version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File Name: 'Microsoft.WindowsAzure.Accelerator, Version=1.0.0.0, Culture=neutral, PublicKeyToekn=null' at Microsot.WindowsAzure.Accelerator.Program.Main<String[] args>"

When working with the solution I have done the following things/changes:

  • Made the necessary changes as detailed in the getting started guide
  • Uninstalled the Azure tools & SDK as I had the latest version 1.3
  • Installed Azure tools & SDK version 1.2 as the solution was unable to build without using the 1.2 version of the DLLs
  • Changed the projects from X64 to All CPUs as also I could not get the solution to build as I am running on a 32bit machine (Windows 7)
  • The solution now build perfectly fine without any errors or warnings

Can you suggest or help me to resolve this problem please.

Thanks,
Warren

Jan 11, 2011 at 4:11 PM

Hi Warren - the error "An attempt was made to load a program with an incorrect format." makes me feel it's probably to do with your penultimate bullet point. It could be that you're building the assembly to a platform which is incompatible to the one running on Azure.

It should still be possible to build x86 libraries for testing on your own machine and x64 ones for deployment, however a caveat: I've no experience with Azure Accelerators so not sure of the specifics of your app.

Jan 11, 2011 at 4:18 PM

Hey Alex,
I have the exact same error in the cmd line window when I had a Morten C running a 64bit machine compile the solution for me and that version of AccelCon.exe gave the same exact error.

However Morten C was able to get the solution to build fine and connect and upload the VHD to Azure just fine as expected with the exact same settings as me.
So I am not sure if this is just down to my OS being a problem (32bit Win7)

Hopefully someone can give me a definitive answer on this.

Thanks,
Warren 

Jan 14, 2011 at 3:56 PM

Hello All,
Well with the help of a Microsoft Azure contact I was able to resolve this problem.

For anyone in a same situation as me, you need to ensure one thing is installed/setup on your machine.

  • Goto Control Panel
  • Programs & Features
  • Turn Windows features on or off
  • Scroll down the list until you find "Internet Information Services Hostable Web Core"
  • Make sure this is enabled/checked

Enabling this setting and rebuilding the solution and re-running the AccelCon application from the Azure SDK Command Line tool and it worked perfectly.

Warren :)